Back to overview
Resolved

Authentication issue for some users

Aug 20, 2026 at 10:00am UTC
Affected services
North America API

Resolved
Aug 20, 2026 at 10:30am UTC

Issue has been fully resolved and confirmed. Remediation work is underway to ensure this doesn't happen again.

Created
Aug 20, 2026 at 10:00am UTC

A backend limit prevented new authentications on the North America cluster, and resulted in server 500's. The root cause was identified and remediated immediately.