Energy API Outage
Updated
Apr 11, 2026 at 10:44am UTC
Many users have reported the workaround is working as expected, however it may require you to manually reload the Home Assistant integration to recover full functionality. After performing the energy authentication, go to the Teslemetry integration, and click the three dots to reload.
I still have not received any communication from Tesla.
Affected services
Updated
Apr 11, 2026 at 4:59am UTC
A workaround for the Energy API issue has been implemented.
This involves using a second application registration specifically for the Energy APIs. If you use Energy products with Teslemetry, the next time you login you will be prompted to authorise a second application for only the energy scopes.
If you use Home Assistant, this will be achieved through a re-authentication prompt.
If required, you can manually trigger this process by visiting https://teslemetry.com/energy_login
Tesla still has not responded, and it is my hope that this workaround will be temporary once I am able to sort this out with Tesla.
Affected services
Updated
Apr 10, 2026 at 8:40am UTC
There is unfortunately no new update on the Energy API outage at this time. Tesla still has not responded to direct emails, support request, or escalation. I will continue to monitor the situation and if we do not receive a satisfactory response from Tesla tomorrow I will start implementing an alternative solution. I intend to compensate all impacted customers once we understand the full impact of the outage.
Affected services
Updated
Apr 9, 2026 at 10:20pm UTC
A change has been deployed to the API server to allow the Home Assistant integration to start without the energy APIs, which should resolve access to Vehicles only. I am still awaiting a response from Tesla.
Affected services
Updated
Apr 9, 2026 at 8:53pm UTC
Tesla has been contacted to investigate this outage. An update is being pushed to the API server to stop returning 403 responses which should resolve the re-authentication issues in Home Assistant and Homey in the meantime.
Affected services
Created
Apr 9, 2026 at 5:00pm UTC
A large number of customers are reporting an energy API outage with 403 responses. Internal telemetry suggests this is when the incident began.
Affected services