Back to overview
Downtime
Cloudflare Load Balancer Outage
May 11, 2026 at 5:40pm UTC
Affected services
Website
Resolved
May 11, 2026 at 8:50pm UTC
The Cloudflare load balancer subscription has been restarted and all pools and nodes have been re-enabled. Everything is functioning normally again.
Affected services
Created
May 11, 2026 at 5:40pm UTC
Without notice, Cloudflare disabled Teslemetry's load balancer subscription resulting in the Teslemetry.com website becoming inaccessible.
Fallback DNS records allowed the Teslemetry API and Fleet Telemetry collectors to continue operating without global load balancing which may have slowed some requests, but should have remained completely operational.
Affected services