Back to overview
Resolved
Backend issues in NA region
Jun 19, 2026 at 9:32am UTC
Affected services
Website
North America API
Resolved
Jun 19, 2026 at 9:40am UTC
The Teslemetry backend suffered an out of memory crash. We are still trying to understand how this happened, but the service has been restored.
Affected services
Created
Jun 19, 2026 at 9:32am UTC
Investigating
Affected services