Back to overview
Degraded

Stability issues

Jun 19, 2026 at 6:00pm UTC
Affected services
North America API

Resolved
Jun 20, 2026 at 2:00am UTC

After the previous incident, our Tesla OAuth Refresh service had hung, causing users to gradually lose their Tesla authentication. The service was manually restarted and monitored to ensure service fully restored. We are making changes to ensure this refresh service is more resilient to issues like this in the future. We apologies for the interruption and appreciate everything who reached out to report issues.

Created
Jun 19, 2026 at 6:00pm UTC

Multiple users have reported stability issues with the API service that is preventing Home Assistant from starting. We have identified another issue with the Teslemetry backend that may have been causing this failure.