Fleet Telemetry configuration is unreliable
Resolved
Jul 27, 2026 at 1:35am UTC
A workaround has been implemented, however we believe the original issue is still present and there is a risk it may apply to our workaround. There is no longer any customer impact but we will continue to monitor this situation closely.
Affected services
Updated
Jul 26, 2026 at 10:52pm UTC
Teslemetry has raised a support request with Tesla regarding this issue, however we have also confirmed that other third parties are not impacted, and telemetry clearly shows this issue has only started in the last 5 days. This typically indicates a direct action by Tesla against the Teslemetry client.
We are making service changes to reduce the backoff and retry mechanisms, and may even start proactively blocking requests where a 500 is expected, in an attempt to "reset" our access.
Affected services
Created
Jul 26, 2026 at 5:05am UTC
We have observed that changing vehicle configuration is unreliable, and Tesla is inconsistently returning 500 status codes on vehicle configuration changes. Existing vehicle configuration is not impacted, and we suspect this issue will self-resolve in time.
Affected services